読者です 読者をやめる 読者になる 読者になる

SideCI Blog

自動コードレビューサービスSideCIを提供している株式会社アクトキャットのコーポレートブログです。



SideCIにPHP Composer Outdated機能追加. 外部packageのバージョンアップをお知らせします

SideCIにてPHP向け新機能、「PHP Composer Outdated」を追加致しました。

「PHP Composer Outdated」はComposerでライブラリのバージョン管理を行っているプロジェクト・レポジトリでご利用になれます。

SideCIが自動的にcomposer.lockに記載されているpackageの最新版のバージョンを取得、現在のバージョンと比較し、新しいものをSideCIの画面上で見られるようにしました。

SideCI上でのPHP Composer Outdatedイメージ 動作イメージ図

使用の前提条件として、composer.lockcomposer.jsonの2ファイルがレポジトリのルートディレクトリに配置されている必要があります。もし異なる位置に配置されているようでしたら、お手数ですが、SideCI内お問い合わせにてお問い合わせ下さい。

2015年7月20日時点ではcomposerにはcomposer outdatedコマンドは存在しませんので、ぜひSideCIを使ってお手軽にバージョンを確認下さい。
参考: GitHub Issue, Proposal: adding a composer outdated command #3771

SideCI上で「PHP Composer Outdated」をAppSettingページより有効にして頂き、「Save and Run now」ボタンやPullRequestを新しくOpenして頂くことなどによって解析が実施され、結果がSideCI画面上で表示されます。

SideCIでの本機能の導入は会員登録を含めても30秒とかかりませんので、ぜひご利用下さい。

SideCI
https://www.sideci.com/


追記: SideCIのComposer Outdated機能は2017/2/22をもって廃止されました。